Page 1 of 1

Issue with v2 of document

PostPosted: Fri Dec 25, 2015 4:46 am
by fzlam

Seems like there is something wrong with my install of OnlyOffice. I have installed the latest using docker containers and I installed CommunityServer and DocumentServer. I have no interest in the MailServer module so that was not installed. Everything works fine except after I edit a document. Here is what is happening. I can create a new .docx and .xlsx and open the new document in the Online Editor. I can also edit the sample .docs and .xlsx (OnlyOffice Sample Spreadsheet.xlsx etc). I can also upload a .xls and have it convert to .xlsx. So all that is good. The problem is when I edit the documents or spreadsheets. Once I change a cell in a spreadsheet and close the browser tab, it would create a new version and change the file size to 22 bytes no matter what the original file size is. I can go into the file system under "/var/www/onlyoffice/Data/Products/Files/0/folder_1000/file_x" and see the folders v1 and v2. I can see in the folder v1 that there is the file "content.xlsx" with the original file size. I then look in the folder v2 and see "content.xlsx" which was 22 bytes. There is also a file that varies in size. In the GUI, I see the "current" version of the file size is also 22 bytes. When I try to open the current version, it will fail with "Conversion Failed". This happens to every file that I edit and save, whether it was converted after upload to OnlyOffice or created directly in OnlyOffice. I have tried to look at all the logs and I cannot see what is wrong. This error only happens after I edit a file and create v2 of the file. It almost seems like it is trying to open up the 22 bytes file which of course it will fail since not all the data is there. Any idea what is wrong?

This is what the document looks like in the GUI:

GUIError.jpg (37.49 KiB) Viewed 1758 times

This is what shows in the file system:

FS.jpg (129.6 KiB) Viewed 1758 times

This is the conversion error when I tried to open up the "current" or v2 of the file:

ConversionError.jpg (78.54 KiB) Viewed 1758 times

Re: Issue with v2 of document

PostPosted: Sat Jan 23, 2016 11:28 am
by Kate

We would like to note, that this forum is devoted to discuss ONLYOFFICE cloud (SaaS) solution.

We invite you to post your question with all your screenshots attached to our another forum, which is created for discussion of ONLYOFFICE server / open source version.