Shortcuts do not work

Discussion of issues you faced using ONLYOFFICE
Post Reply
RrBd
Posts: 8
Joined: Mon Feb 11, 2019 5:59 am

Shortcuts do not work

Post by RrBd » Thu Oct 17, 2019 1:04 pm

Since August 2019 or so keyboard shortcuts like <cntrl+c> for 'copy' and similar do no longer work with my unzipped unofficial (by wg9s) en-US SeaMonkey 2.53 (NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20190801120006 (Default Classic Theme, German Language Pack active) on German WIN7 64bit

Seems to be a browser sniffing problem, switching User Agent String to "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:67.0) Gecko/20100101 Firefox/67.0" heals the problem.

I dislike those browser sniffing problems, any alternatives to workaround with fake user agent string?

CU

Rainer

Kate
Posts: 246
Joined: Mon Feb 09, 2015 11:17 am

Re: Shortcuts do not work

Post by Kate » Thu Oct 17, 2019 1:56 pm

Hello,

In the online version, the following key combinations are only used to copy or paste data from/into another document or some other program, in the desktop version, both the corresponding buttons/menu options and key combinations can be used for any copy/paste operations:

Ctrl+X key combination for cutting;
Ctrl+C key combination for copying;
Ctrl+V key combination for pasting.

To resolve this issue, please, empty the cache and clear the cookies of the browser you work in and then try again.

RrBd
Posts: 8
Joined: Mon Feb 11, 2019 5:59 am

Re: Shortcuts do not work

Post by RrBd » Thu Oct 17, 2019 2:05 pm

I should have explained some more precise what "oe not work" means ...

Steps how to reproduce (for me) with https://personal.onlyoffice.com/product ... 5NDA0OTki0:

1. Open document
2. click on A4
3. <cntrl+c> for copy
» Expected: cell contents -> clipboard
actual: a "c" appears in the cell

This problem can be healed with the fake User Agent String.

Additional Info:
a) Safe mode (all add-ons disabled) does not heal the problem
b) No problem when I use a newly created SeaMonkey User Profile

CU

Rainer

RrBd
Posts: 8
Joined: Mon Feb 11, 2019 5:59 am

Re: Shortcuts do not work

Post by RrBd » Thu Oct 17, 2019 2:13 pm

I additionally presented the problem in Usenet Newsgroup mozilla.support.seamonkey

RrBd
Posts: 8
Joined: Mon Feb 11, 2019 5:59 am

Re: Shortcuts do not work ✔

Post by RrBd » Sat Oct 19, 2019 5:50 pm

Results from NG:
I can confirm the same behaviour. "Advertise Firefox Compatibility" seems to be what makes the difference. It's enabled in a new profile, but not in my usual profile. So another case of dodgy browser detection on the website's part. Presumably they changed something around August which introduced the problem.
Indeed, that preference heals the problem.

CU

Rainer

Post Reply